Can I use jDownloader 1 (v.0.9) with Premiumize.me? Back to Knowledgebase

We do not support jDownloader 0.9 anymore as it was deprecated by jDownloader developers and it has been replaced by the new jDownloader 2.

Please find a short setup guide here.