Have a Question?

If you have any question you can ask below or enter what you are looking for

Knowledgebase / Services / Can I use jDownloader 1 (v.0.9) with Premiumize.me?

We do not support jDownloader 0.9 anymore as it was deprecated by jDownloader developers and it has been replaced by the new jDownloader 2.

Please find a short setup guide here.

Looking for help?

Couldn’t find what your are looking for ? Create a new ticket so that we can help you.

Ticket Center

Was this article helpful to you?